RAK535 在飞思卡尔imx287平台上的驱动移植问题



  • 按照以下步骤移植:
    ATH6KL-LSDK-WLAN-AIO-OSR-5.0.0.x Release

    [Build Procedure]

    Step 1:
    Extract ATH6KL-LSDK-WLAN-AIO-OSR-5.0.0.xx.tgz.
    Go to WLAN-AIO-OSR/ as working folder

    cd WLAN-AIO-OSR/

    Step 2:
    Build patch codes. Please add kernel option to indicate Linux kernel version.

    cd WLAN-AIO-OSR/build/scripts/n32926_o1
    modify config.n32926_o1

    export KERNELPATH=/home/wgzh/rakbspv3.2_lunuo/linux-2.6.35.4_fa92.spi_bk
    export KERNELARCH=arm
    export TOOLPREFIX=arm-linux-
    export TOOLCHAIN=/usr/local/arm_linux_4.2/bin

    Step 3:
    Build codes. Please add kernel option to indicate Linux kernel version.

    cd WLAN-AIO-OSR/build/
    make BOARD_TYPE=n32926_o1

    在Step3 编译时,提示
    0_1497403805910_QQ图片20170614092847.png

    imx287的版本是2.6.35,RAK535驱动对内核的版本有没有要求,有人遇到这个问题吗?



  • @tcbwang 可能对应没有定义,把那一行屏蔽掉试下



  • @gz 屏蔽了之后,更多的编译错误,行不通



  • @tcbwang 有log信息可以贴出来看看吗?


登录后回复
 

与 RAK支持中心 的连接断开,我们正在尝试重连,请耐心等待